Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
PoMOgiTe212lk
31.01.2022 19:58 •
Информатика
Написать программу в паскаль 1) дано n число, верно ли, что сумма его цифр четное число 2) найдите сумму его цифр больше 5 !
Ответ:
svetagrigorenko
08.10.2020 19:00
Первая
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
a:=a + (n mod 10);
n:=n div 10;
end;
end.
Вторая
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
if n mod 10>5 then
begin
a:=a + (n mod 10);
end;
n:=n div 10;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
XMuhamedKinggX
31.05.2023 18:50
Дана точка на плоскости с координатами (x,y). Составить программу, которая выдаёт одно из сообщений да , нет , на границе в зависимости от того, лежит ли точка внутри заштрихованной...
dmxboy
03.01.2021 02:14
Расскажите о том как защитить информацию в компьютере от компьютерных вирусов...
morfisleep
14.08.2022 22:02
Презентація на тему: пристрої для передавання інформац хотя бы чем то ...
Anjik20125
08.09.2021 03:04
Указатель на указатель Создать двумерный массив 5х5, заполнить его случайными числами от 10 до 99 и вывести на экран. Поменять местами максимальный элемент каждой строки с первым...
Юлия0753
18.08.2020 06:45
Нужно доработать программу, таким образом, чтобы выводилось количество шагов, потребовавшихся для угадывания числа. , program ugaday; var l,r,n,c: integer; y: 0..1; begin writeln(...
полина2125
17.03.2021 02:01
СОР ПО ИНФОРМАТИКЕ ЗА 5 КЛАСС. ЗА ОТВЕТ ...
Дарья122004
20.12.2021 20:34
Расшифруйте текст: ьоДдж ш ленсв ю чо.ьмтУороб лы онмго.л жу Метод: перестановка Ключ: 52143...
zhansaya77
29.12.2020 08:52
40 когда щелкаешь по данному ярлыку, открывается папка, содержащая ссылки на все диски и дисководы, имеющиеся на пк, а также на системную папку панель и на папки с пользовательскими...
boha3
18.08.2022 06:45
Не количество букв четное или первая буква согласная 1)омск 2)иваново 3)москва 4)кировск...
чтлза
28.03.2023 10:34
30 составить программу нахождения произведения значений элементов массива состоящего из 10 целых чисел. значение элементов массива заданы с формулы a[i]: = i*i-1...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
a:=a + (n mod 10);
n:=n div 10;
end;
end.
Вторая
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
if n mod 10>5 then
begin
a:=a + (n mod 10);
end;
n:=n div 10;
end;
end.