Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Maxbys
24.02.2021 14:17 •
Информатика
С++ напишите программу, которая в четырехзначном числе меняет местами цифры сотен и десятков. вывести полученное число. ввод вывод 1267 1627
Ответ:
Danya135evlanov
08.10.2020 18:56
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64
#include <iostream>
using namespace std;
int main()
{
int number;
cin >> number;
number = 1000 * (number / 1000) + 100 * (number / 10 % 10) + 10 *
(number / 100 % 10) + number % 10;
cout << number;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ангел769
12.11.2022 17:58
6. В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления. Правила выполнения...
Ротср
12.12.2021 06:26
Зашифруйте слово компьютер графическим символьными числовым...
Kairas
09.10.2020 14:29
Свойство автоматического наращивания имеет поле:...
123GEV
31.05.2021 00:44
Информатика 9 класс вывести на экран в строчку числа от 1 до 20....
дншегзпгх
31.05.2021 00:44
Сколько страниц текста (60 строк по 55 символов) можно записать на дискету емкостью 720 кб?...
кирил2088
19.01.2023 14:59
Даны два трехзначных числа. найдите шестизначное число, образованное из двух данных чисел путем дописывания второго числа к первому справа. с решением,...
tanysha29
19.01.2023 14:59
Людмила защищает свои пароли так: двигаясь от краев пароля к его центру, она меняет местами каждую вторую пару символов. например, пароль pas sword превращается в prsws...
PetryxaMakvin
19.01.2023 14:59
Одномерный массив из 12 элементов заполнить случайным образом числами от 0 до 50. если пятый элемент таблицы меньше десятого элемента,то присвоить этим элементам удвоенное...
kozhoeva2003
19.01.2023 14:59
:определить сумму элементов матрицы кратных 3 вот решение : program crh; const n=5; m=6; var a: array [1..n,1..m] of integer; i,s: integer; begin for i: = 1 to n do...
zD3VOLYx
19.01.2023 14:59
Pascal . введено трёхзначное число.если сумма его цифр нечетна, но увеличить чисто вдвое...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
using namespace std;
int main()
{
int number;
cin >> number;
number = 1000 * (number / 1000) + 100 * (number / 10 % 10) + 10 *
(number / 100 % 10) + number % 10;
cout << number;
}