В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
daniilprok2004
daniilprok2004
04.10.2021 06:17 •  Информатика

Много программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 4. программа получает на вход количество чисел в последовательности, а затем сами числа. количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: количество чисел, кратных 6 и оканчивающихся на 4. input 3,24,25,54 result2

Ответ:
Дайяник
Дайяник
08.10.2020 18:10
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqInteger(ReadlnInteger)
      .Where(t->(t mod 6=0) and (t mod 10=4)).Count.Println
end.
0,0(0 оценок)
Ответ:
MilaPlay123
MilaPlay123
08.10.2020 18:10
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
    size_t size, value, count; 
    cin >> size;
    vector<int> v;
    for (size_t i = 0; i < size; ++i) { 
        cin >> value; 
        v.push_back(value); 
    }
    count = count_if(v.cbegin(), v.cend(), [](const int& i) { return (i % 6 == 0) | (i
% 10 == 4); });
    cout << count;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?