В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Дана прямоугольная матрица размера nxm, (n≠m). составить программу для: формирования одномерного массива,содержащего средние значения каждого столбца матрицы. язык программирования с++.

Ответ:
кристина2155
кристина2155
08.10.2020 17:31
#include <iostream>using namespace std;int main(){ int n, m; float M[100][100], R[100]; cout << "vvedite n && m" << endl; cin >> n >> m; for(int i = 0; i < n; i++) { for(int j = 0; j < m; j++) { cin >> M[i][j]; } } for(int i = 0; i < n; i++) { float a = 0.; for(int j = 0; j < m; j++) { a += M[i][j]; } R[i] = float(a) / m; } for(int i = 0; i < n; i++) { cout << R[i] << endl; }}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?