В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
elisavetafolst
elisavetafolst
10.05.2021 21:02 •  Информатика

Программисты, нужно написать программу на паскале дано натуральное число n. найти произведение нечетных чисел от 1 до n. c longint и integer.

Ответ:
nutka1980
nutka1980
08.10.2020 17:15
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  Writeln(Range(1,ReadInteger,2).Aggregate(BigInteger(1),(p,q)->p*q))
end.
0,0(0 оценок)
Ответ:
Лопамрлш
Лопамрлш
08.10.2020 17:15
Var
  n, i: integer;
  pr: longint;

begin
  readln(n);
  pr := 1;
  i := 1;
  while (i <= n) do begin
    i := i + 2;
    pr := pr * i;
  end;
  pr := pr div i;
  writeln(pr);
end.
Программисты, нужно написать программу на паскале дано натуральное число n. найти произведение нечет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?