В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
speedoflight3
speedoflight3
19.07.2021 04:44 •  Информатика

Вцелочисленном массиве из 10 эл. найти произведение четных чисел и вывести его. (+написать программу в паскале)

Ответ:
Юриякамория
Юриякамория
08.10.2020 17:06
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,-999,999); a.Println;
  Writeln('П=',a.Where(t->t.IsEven).Aggregate(BigInteger(1),(p,q)->p*q))
end.

Пример
112 -439 -766 -476 -83 718 742 -303 -20 126
П=-54825504325079040
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?