В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Cerega67
Cerega67
04.01.2021 20:51 •  Информатика

Написать программу которая выводит в одномерном массиве заданным вводом данных с клавиатуры вычисляет сколько среди них чисел больших среднего арифметичского числа паскаль

Ответ:
viktorijavorob
viktorijavorob
16.08.2020 21:46

const n=13;

var a:array [1..n] of integer;

i,s,k:integer;

begin

write('Введите ',n,' элементов массива через пробел: ');

for i:=1 to n do read(a[i]);

write ('Массив: ');

for i:=1 to n do write(a[i],'  ');

writeln;

for i:=1 to n do s:=s+a[i];

writeln('Среднее арифметическое всех элементов массива равно: ',s/n:0:3);

for i:=1 to n do if a[i]>s/n then k:=k+1;

write('Элементов массива больших среднего арифметичского всех элементов массива: ',k);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?