В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
elinamar
elinamar
22.01.2023 02:52 •  Информатика

Написать программу на языке с++(желательно в компиляторе shell c++)

напишите программу, которая сортирует массив и находит количество различных чисел в нем.
программа 8-9 класса

решите, надо!
заранее .

Ответ:
svesda2
svesda2
08.10.2020 16:38

#include <iostream>

using namespace std;

int main() {

int n, a=1;

cin>>n; //Кол-во элементов массива

int arr[n];

for (int i=0; i<n; ++i) cin>>arr[i]; //Ввод массива

for (int i=0; i<n-1; i++) { //Сортировка по возрастанию

 for (int j=0; j<n-i-1; j++) {

  if (arr[j]>arr[j+1]) {

                int temp=arr[j];

                arr[j]=arr[j+1];

                arr[j+1]=temp;

        }

    }

}

for (int i=0; i<n; ++i) cout<<arr[i]<<" "; //Вывод массива

cout<<endl;

if (n==1) cout<<a;

else {

 for (int i=1; i<n; ++i) {

  if (arr[i]>arr[i-1]) ++a;

 }

 cout<<a; //Вывод кол-ва различных значений элементов массива

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?