В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anilop11
Anilop11
27.04.2023 10:30 •  Информатика

Написать код к : напишите программу, которая будет определять наибольшую цифру во введенном трехзначном числе.

Ответ:
mrnazar228
mrnazar228
08.10.2020 16:12
Var
a: integer;
a1, a2, a3, max: byte;
begin
readln(a);
a1 := a div 100;
a2 := a mod 100 div 10;
a3 := a mod 10;
max := a1;
if (a2 > max) then
max := a2;
if (a3 > max) then
max := a3;
writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?