В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Gambuker
Gambuker
09.04.2022 13:27 •  Информатика

Написать программу на паскале по функции z=a2-b/a-1 если а=0, то решения нет, потому что на 0 делить нельзя и если a< > 0

Ответ:
Dedula5
Dedula5
08.10.2020 16:00
Не понял с a2, если не квадрат, то позже исправлю

program func;
 
var
  a, b: integer;
  z: real;
 
begin
  writeln('Введите a и b');
  readln(a,b);
  if a=0 then
    writeln('Решения нет')
  else if a<>0 then
    begin
    z:=((Sqr(a)-b)/(a-1));
    writeln('z=',z);
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?