В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
marinastolarova
marinastolarova
07.06.2021 06:17 •  Информатика

Составьте программу паскаль для нахождения всех счастливых автобусных билетов чтобы из низ извлекался квадратный корень

Ответ:
astakastaj
astakastaj
08.10.2020 16:00

Программа, которая сравнивает первые 3 со вторыми 3мя ниже, но я не понял к чему было упоминание корня в первоначальном задании

Program bilet;
var

a,b,c:longint;
i:byte;
begin
writeln('vvrdite nomer');
readln(a);
b:=0;
c:=0;
for i:=1 to 6 do
    if i<4 then begin
       b:=b+(a mod 10);
       a:=a div 10;
       end
    else begin
         c:=c+(a mod 10);
         a:=a div 10;
    end;
if b=c then writeln('schastlivuy ',c,' = ',b)
else writeln('uvyu ',c,' <> ',b);
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?