В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
muradir1102
muradir1102
17.09.2021 22:53 •  Информатика

Составить программу по условию: дан массив из 10 элементов.найти сумму элементов, кратных 3 и двузначных. массив задан случайно на паскале

Ответ:
NikitaZdanovich
NikitaZdanovich
27.08.2020 06:46

Так как задание не формализовано выводит последовательно суммы кратных 3 и двухзначных чисел

Program TZ5;
const
n=10;
var
a:array [1..n] of integer;
i,b:integer;
begin
randomize;
for i:=1 to n do begin
 a[i]:=random (20);
 a[i]:=a[i]-10;
        writeln(i,'  ',a[i]);
end;
b:=0;
for i:=1 to n do
    if (a[i] mod 3)=0 then
       b:=b+a[i];
writeln('summa kratnyh 3m=',b);
b:=0;
for i:=1 to n do
    if abs(a[i]) >9 then b:=b+a[i];
writeln('summa dvuhznachnyh =',b);
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?