В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zaijiki
zaijiki
09.11.2022 11:24 •  Информатика

Напишите программу, которая в последовательност натуральных чисел определяет, все ли числа в последовательности трехзначные. программа получает на вход последовательность чисел заканчивающимся нулем. вход: 35,717,405,225,0 выход: no

Ответ:
ABILAIKhan
ABILAIKhan
08.10.2020 15:39
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  if ReadSeqIntegerWhile(t->t<>0).Any(t->(t<100) or (t>999)) then
    Writeln('No')
  else Writeln('Yes')
end.

Пример
35 717 405 225 0
No
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?