В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mashamelnik28
mashamelnik28
08.12.2022 05:48 •  Информатика

Составьте программу для вычисления выражения в паскале x=sin 2y+cos 2z/корень из sin y*cos z

Ответ:
elmirayanbukov
elmirayanbukov
10.09.2020 16:16
Поскольку автор вопроса не откликается, а представленное в вопросе выражение может интерпретироваться по-разному, было принято решение записать формулу "как есть", т.е. в предположении, что она записана верно и скобки в ней не были нужны.

\displaystyle x=\sin 2y+ \frac{\cos 2z}{\sqrt{\sin y}}\cos z

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (y,z):=ReadReal2('Введите y и z:');
  var x:=Sin(2*y)+Cos(2*z)/Sqrt(Sin(y))*Coz);
  Writeln('x=',x)
end.
0,0(0 оценок)
Ответ:
Ален4ик179
Ален4ик179
10.09.2020 16:16
Prograg zd0;
Var x,y,z:integer;
Begin
Readln(y,z);
x:=SIN(2*y)+(COS(2*z)/SQRT(SIN(y)*COS(z)));
Writeln(x);
enb.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?