В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mishazzzzz
mishazzzzz
19.03.2020 23:16 •  Информатика

Составить программу для ввода с клавиатуры некоторого массива чисел типа integer или real с правильным диалогом программы и пользователя. на всякий случай: имена переменных в программах у обучающихся совпадать не должны. также следует обеспечить диалог с пользователем. в программе обязательны ! комментарий по ходу выполнения программы давать вразумительный

Ответ:
fat10
fat10
08.10.2020 14:44
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество элементов в массиве:');
  var a:=ReadArrReal('Вводите элементы массива через пробел или Enter',n);
  Writeln('Ввод завершен')
end.

Пример
Количество элементов в массиве: 5
Вводите элементы массива через пробел или Enter 3.5 7 -2.9 0.4 11.345
Ввод завершен
0,0(0 оценок)
Ответ:
Виктория54345888
Виктория54345888
08.10.2020 14:44
Язык не указан, так что напишу на паскале ABC.

const
  maxn = 100;

type
  myarr = array [1..maxn] of integer;

var
  a: myarr;
  n, i: integer;

begin
  writeln('Введите размер массива:');
  readln(n);
  writeln('Введите массив:');
  for i := 1 to n do
    read(a[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?