В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Makalllla1122
Makalllla1122
19.03.2020 23:16 •  Информатика

Напишите программу на языке pascal для следующей : определить число n, при котором сумма квадратов ряда чисел 1, 2, …, n не превысит некоторого целого числа k, т.е. число k вводится с клавиатуры

Ответ:
Гуля2345
Гуля2345
08.10.2020 14:43
//программа определит максимальное n
program qwerty;
var a, k, sum:integer;
begin
readln(k);
a:=1;
while((sum+a*a)<=k) do begin
sum:=sum+a*a;
a:=a+1;
end;
writeln(a-1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?