В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Leonardo81
Leonardo81
29.10.2022 06:42 •  Информатика

(желательно с пояснением) 1. запишите на языке паскаль массив с, в котором 7 элементов, заданных оператором присваивания. вывод в столбик. 2. создать одномерный массив c из 12 целых элементов. числа вводит пользователь с клавиатуры. вывести на экран массив в виде строки чисел. 3. напишите программу, реализующую заполнение случайными числами 15 элементов массива s и вывод их на экран. элементы массива – это целые числа из промежутка [0; 40]. 4. напишите программу, реализующую заполнение 25 числами массива b по формуле и вывод их на экран в строку по формату: целая часть – 9 позиций, дробная – 3 позиции. формула: элемент массива равен сумме двух предыдущих элементов, деленной на номер текущего элемента, т.е. третий элемент равен (первому + второму)/3(индекс третьего) и т.д. значения первого и второго элемента: b[1]: =3; b[2]: =6;

Ответ:
маркен2
маркен2
08.10.2020 14:37
1. var
a:array[1..7] of integer;
i:Integer;
begin
//заполнение массива
a[1]:=3;
a[2]:=8;
a[3]:=2;
a[4]:=0;
a[5]:=2;
a[6]:=1;
a[7]:=7;
//вывод массива
for i:=1 to 7 do
Writeln(a[i]);
end.

2. var
c:array[1..12] of integer;
i:Integer;
begin
//заполнение массива
for i:=1 to 12 do
begin
Writeln('Введите ',i,' элемент массива');
readln(c[i]);
end;
//вывод массива
Writeln('Массив');
for i:=1 to 12 do
Write(c[i],' ');
end.

3.var
s:array[1..15] of integer;
i:Integer;
begin
//заполнение массива
for i:=1 to 15 do
s[i]:=random(40);
//вывод массива
Writeln('Массив');
for i:=1 to 15 do
Write(s[i],' ');
end.

4.var
b:array[1..25] of Real;
i:Integer;
begin
//заполнение массива
b[1]:=3;
b[2]:=6;
for i:=3 to 25 do
b[i]:=(b[i-1]+b[i-2])/i;
//вывод массива
Writeln('Массив');
for i:=1 to 25 do
Write(b[i]:9:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?