В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Brаun
Brаun
15.08.2021 16:40 •  Информатика

Паскаль написать программу для нахождения суммы большего и меньшего из трех чисел. указание: для решения использовать подпрограммы вычисления минимального и максимального для двух чисел. пример на входе: 45 72 24 на выходе: 96

Ответ:
baryshnikova20
baryshnikova20
08.10.2020 14:13
Var
  a, b, c: integer;

function min_3(const a, b, c: integer): integer;
var
  local_min: integer;
begin
  if (a < b) then
    local_min := a
  else
    local_min := b;
      if (c < local_min) then
    local_min := c;
      Result := local_min
end;

function max_3(const a, b, c: integer): integer;
var
  local_max: integer;
begin
  if (a >= b) then
      local_max := a
  else
      local_max := b;
       
  if (c > local_max) then
      local_max := c;

  Result := local_max;
end;

begin
  writeln('Введите a, b, c -> ');
  readln(a, b, c);
  writeln('Результат: ', min_3(a, b, c) + max_3(a, b, c), '.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?