В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Pascal.abc составьте программу! на марс отправляется туристический космолет, который может иметь на борту не более 750 пассажиров. туристы прибывают группами, количество человек в которых различно. составьте программу, регулирующую наполняемость космолета, а также вычисляющую необходимое количество гидов (по одному на группу).

Ответ:
arslanbaiguskap0c2gw
arslanbaiguskap0c2gw
08.10.2020 14:11
Program p1;
uses crt;
var a,g,i,s,s2:integer;
begin

I:=1;
s:=0;

  while i<>0 do begin
     read(a);
    s:=s+a;
     If s>=750 then begin
      i:=0;
    end;
    
      If s<=750 then begin
        g:=g+1;
        end;

end;

  If s>750 then begin
     s2:=s-750;
    writeln( ' Не осталось мест для  ',s2);
 end;

    If s>750 then begin
      s2:=s-a;
     writeln('Всего попало на космолёт  :',s2);
  end;
  749
writeln('Понадобилось гидов :',g);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?