В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Нужна с программированием в pascal. напишите программу на : "дано действительные числа a,b,c . если a> b> c , то числа оставить без изменений, в противоположном случае все числа заменить на их квадраты"

Ответ:
levyjigor45
levyjigor45
08.10.2020 13:48
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

1. Современное решение

begin
  var (a,b,c):=ReadReal3;
  if (a>b) and (b>c) then else (a,b,c):=(a*a,b*b,c*c);
  Println(a,b,c)
end.

Пример
15.8 4.9 13
249.64 24.01 169

2. А так, увы, все еще учат писать во многих школах...

program Toska; 

var
  a,b,c:real;

begin
  Read(a,b,c);
  if not ((a>b) and (b>c)) then begin
    a:=a*a; b:=b*b; c:=c*c
    end;
  Writeln(a,' ',b,' ',c)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?