В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
veronikamantul
veronikamantul
09.11.2020 09:25 •  Информатика

Написать программу в с++. задан двумерный массив y из 7-и строк и 3-х столбцов. составить программу, которая вычисляет значение суммы произведений элементов строк

Ответ:
pwgamerproyt
pwgamerproyt
08.10.2020 13:30
#define N 7
#define M 3
#include <iostream>
using namespace std;
int main() {   
    float Y[N][M];
    // Ввод данных
    for (int i = 0; i < N; i++)
        for (int j = 0; j < M; j++)
            cin >> Y[i][j];

    float sum = 0, prod = 0;
    for (int i = 0; i < N; i++) {
        prod = 1;
        for (int j = 0; j < M; j++) {
            prod *= Y[i][j];
        }
        sum += prod;
    }
    cout << "Sum: " << sum << ".\n";
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?