В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
abdulismailova2
abdulismailova2
12.11.2022 06:38 •  Информатика

Яне понимаю в программировании. имеется , решенная в turbo pascal. нужен алгоритм ее решения, т.е. расписать какая операция что делает и сколько всего операций. : напишите программу для проверки, есть ли в данном слове буква «а». если есть, то найдите номер первой из них. решение: var a: string; var i: integer; begin writeln('введите слово'); read(a); for i: =1 to length(a) do begin if (a[i]='а') then begin writeln('найдена буква “а”, ее позиция: ' , i); break; end; end; end.

Ответ:
evaeva2006
evaeva2006
08.10.2020 13:27
Алгоритм решения следующий:

Сначала считывается введенное слово в переменную. Далее, в цикле от начала слова и до его конца проверяется, является ли текущая буква, равной искомой, то есть букве "а". Если такая буква найдена, то выводится её позиция в слове.

А теперь комментарий по каждой из строчек кода.

// Блок объявления переменных
var a:string; 
var i:integer;
// Начало программы
begin
// Ввод слова
writeln('Введите слово');
// Считывание слова
read(a);
// Цикл от 1 до длины считанного слова
for i:=1 to length(a) do begin
// Условие на то, является ли текущая буква заданной
if (a[i]='а') then begin
// Если является, вывод её позиции на экран
writeln('Найдена буква “а”, ее позиция:' , i);
// и прерывание дальнейшего цикла, выход из него
break;
// Завершение блока "if"
end;
// Завершение цикла
end;
// Завершение программы
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?