В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dimdasha66
dimdasha66
22.08.2021 11:10 •  Информатика

Составьте программу, которая будет определять положительное или отрицательное число ( программа c++) заранее )

Ответ:
ekhvalebo
ekhvalebo
08.10.2020 12:53
#include<iostream>
using namespace std;
int x;
int main(){
cin>>x;
if(x>0) cout<<"Polozhitelnoye'';
else cout<<"Otritsatelnoye'';
return 0;}

Составьте программу, которая будет определять положительное или отрицательное число ( программа c++)
0,0(0 оценок)
Ответ:
sludkov
sludkov
08.10.2020 12:53
Усложним задание:
#include <iostream>
#include <string>
using namespace std;

template<typename T>
string sign(const T& x)
{
    return x < 0 ? "negative" : x == 0 ? "0" : "positive";
}

int main()
{
    cout << sign(-3.14f);
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?