В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tuzor
tuzor
20.01.2023 19:53 •  Информатика

Написать программу которая сравнивает сумму четных значений с нечетными значением !

Ответ:
uIia454
uIia454
08.10.2020 12:14
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (so,se):=(0,0);
  ReadSeqIntegerWhile(t->t>0).ForEach(t->if t.IsOdd then so+=t else se+=t);
  Write('Сумма четных ',se,' ');
  if se>so then Write('>')
  else
    if se=so then Write('=')
    else Write('<');
  Writeln(' суммы нечетных ',so)
end.

Пример
3245 6774 23241 5645 967 32234 123 65 2134 0
Сумма четных 41142 > суммы нечетных 33286

Программа считывает данные, пока они являются натуральными числами.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?