В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ketrinmaknamar
ketrinmaknamar
18.09.2022 12:03 •  Информатика

Напишите программу, которая считает количество предложений во введенной строке и выводит его. предложение может заканчиваться на: . (точка) ; (точка с запятой) ? (вопросительный знак)

Ответ:
9854123g
9854123g
08.10.2020 12:09
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (s,k):=(ReadlnString,0);
  for var i:=1 to s.Length do
    if s[i] in ['.',';','?'] then k+=1;
  Writeln('Количество предложений равно ',k)  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?