В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
laura050027
laura050027
02.09.2020 14:06 •  Информатика

Напишите программу, которая считывает произвольное количество чисел до стоп-слова "stop" и выводит, сколько раз среди них встречается первое введенное число (включая первое вхождение). sample input: 8 1 6 1 6 10 8 10 1 2 9 4 2 6 3 4 9 3 1 6 10 8 4 9 10 2 3 1 stop sample output: 3

Ответ:
АсяГордиенко
АсяГордиенко
08.10.2020 12:11
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var s1:=ReadlnString;
  if s1='STOP' then Writeln(0)
  else begin
    var k:=1;
    ReadSeqStringWhile(t->t<>'STOP').ForEach(w->if w=s1 then k+=1);
    Writeln(k)
    end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?