В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
бессараб1
бессараб1
22.03.2022 22:37 •  Информатика

Информатика: решение на языке паскаль. текст : даны три натуральных числа. напишите программу, определяющую существует ли треугольник с такими длинами сторон. если такой треугольник существует, то определите его тип (равносторонний, равнобедренный, разносторонний)

Ответ:
Лвлчтчтчтчтчь
Лвлчтчтчтчтчь
04.08.2020 14:39
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadInteger3('a b c =');
  if (a+b>c) and (a+c>b) and (b+c>a) then
    if (a=b) or (a=c) or (b=c) then
      if (a=b) and (b=c) then Writeln('Треугольник равносторонний')
      else Writeln('Треугольник равнобедренный')
    else Writeln('Треугольник разносторонний')
  else Writeln('Треугольник не существует')
end.
0,0(0 оценок)
Ответ:
бабушка111111
бабушка111111
04.08.2020 14:39
Var       
i, a, b, c: integer;

function check_is(a, b, c: integer):
 boolean;
begin     
 if a >= b + c then check_is := false
else        if b >= a + c then
 check_is := false else     
  if c >= a + b then check_is := false else     
         check_is := true;           
       end;
procedure check_how(a, b, c: integer);begin 
     if ((a = b) and (b = c) and (a = c)) then writeln('равносторонний') else   
    if ((a = b) or (b = c) or (a = c)) then writeln('равнобедренный') else              writeln('разносторонний');     
  end;

begin     
 writeln('Введите стороны треугольника');   
    read(a, b, c);   
    if check_is(a, b, c) then check_how(a, b, c) else writeln('Нет такого треугольника!');          
   end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?