Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Indira9786876
05.05.2022 00:29 •
Информатика
C++. составьте программу, где вводят 4-значное натуральное число и переставляет его первую и последнюю цифру. например, 3456 должно получиться 6453
Ответ:
snezhkabo00
08.10.2020 11:26
#include <iostream>
using namespace std;
int main() {
int n;
cin >> n;
int a = n % 10, b = (n / 10) % 10, c = (n / 100) % 10, d = n / 1000;
cout << a * 1000 + c * 100 + b * 10 + d;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
magoomamedzadeh
20.05.2021 02:17
С ИНФОРМАТИКОЙ! У МЕНЯ СОР! ПОДПИШУСЬ СДЕЛАЮ ЛУЧШИЙ ОТВЕТ ЗАДАНИЯ В ТЕЧЕНИИ 15 МИНУТ!...
catikis
05.05.2020 19:29
3. Укажите назначение для следующих ктограмм.ПиктограммаНазначение...
Jujuliliaa
11.10.2021 17:24
2.SketchUp дегенiмiз не? ивт...
asmolova2
13.05.2023 05:13
решить задачку. Олег, Антон и Дима подошли к реке. Каждый мальчик был со своей сестрой. Всем нужно было переправиться на другой берег. В их распоряжении была только одна...
суперкот78
05.06.2022 08:29
Моделдьеу созынын орыша жане агылшынша нускасын жазу комектес ындершы ...
YankaManky
05.03.2022 01:08
Определи абсолютную ссылку формулы:...
leski
11.12.2020 00:23
сделайте два задания на фото...
wtfareudoing
03.03.2021 07:32
Где я могу посмотреть вопрос который задала я...
nastyaborisova13
03.03.2021 07:32
Какие могут быть слова и вопросы для кроссворда по теме дыхание и фотосинтез 6 класс...
MaxRozBerg
03.03.2021 07:32
Небольшое сочинение на тему ночь ,надо написать его без глаголов...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main() {
int n;
cin >> n;
int a = n % 10, b = (n / 10) % 10, c = (n / 100) % 10, d = n / 1000;
cout << a * 1000 + c * 100 + b * 10 + d;
}