В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kelaruu
kelaruu
09.06.2023 10:48 •  Информатика

Составьте программу, которая последовательно запросит 10 целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько нечетных чисел.

Ответ:
naila79
naila79
21.08.2020 13:56
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:integer;
  var (ke,ko):=(0,0);
  for var i:=0 to 9 do begin
    Write('Введите число ',i+1,': '); Read(a);
    if a.IsEven then ke+=1 else ko+=1
    end;
  Writeln('Нечетных чисел ',ko,', четных ',ke)
end.

Пример
Введите число 1: 45
Введите число 2: -25
Введите число 3: 8
Введите число 4: 0
Введите число 5: 16
Введите число 6: 37
Введите число 7: 111
Введите число 8: -5345
Введите число 9: 23
Введите число 10: 15
Нечетных чисел 7, четных 3
0,0(0 оценок)
Ответ:
умница633
умница633
21.08.2020 13:56
Var q,w,e,r,t,y,u,i,o,p,l,s,a: Integer;
begin
writeln('Введите 10 целых чисел');
readln(q,w,e,r,t,y,u,i,o,p);
s:=0;
a:=0;
for l:=0 to 9 do
begin
if l=0 then if q mod 2=0 then s:=s+1 else a:=a+1;
if l=1 then if w mod 2=0 then s:=s+1 else a:=a+1;
if l=2 then if e mod 2=0 then s:=s+1 else a:=a+1;
if l=3 then if r mod 2=0 then s:=s+1 else a:=a+1;
if l=4 then if t mod 2=0 then s:=s+1 else a:=a+1;
if l=5 then if y mod 2=0 then s:=s+1 else a:=a+1;
if l=6 then if u mod 2=0 then s:=s+1 else a:=a+1;
if l=7 then if i mod 2=0 then s:=s+1 else a:=a+1;
if l=8 then if o mod 2=0 then s:=s+1 else a:=a+1;
if l=9 then if p mod 2=0 then s:=s+1 else a:=a+1;
end;
writeln('Чётных: ',s);
writeln('Нечётных: ',a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?