В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
389648
389648
06.04.2023 00:48 •  Информатика

Напишите программу, которая переводит число (возможно, отрицательное), записанное в шестнадцатеричной системе, в десятичную систему. входные данные входная строка содержит шестнадцатеричную запись числа n ( 1 ≤ | n | < 10 9 ). выходные данные программа должна вывести десятичную запись этого числа.

Ответ:
СеверусСнегг
СеверусСнегг
08.10.2020 10:49
#include <iostream>
using namespace std;
int main()
{
    int N;
    setlocale(LC_ALL, "Russian");
    cin >> hex >> N;
    cout << N << endl;
    system("pause");
    return 0;
}

Пример:
27A9A
162458
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?