В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rasulR1
rasulR1
19.04.2022 14:16 •  Информатика

Паскаль. напишите программу, которая запрашивает ввод массива b и выводит на экран его элементы в табличной форме: 1 2 3 4 2 3 4 5 3 4 5 6 выведите на экран среднее арифметическое элементов массива b.

Ответ:
L00KING
L00KING
08.10.2020 09:52
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  var b:=ReadMatrInteger(m,n);
  b.Println(4); Writeln(4*b.ColCount*'-');
  Writeln('Ср.арифм. равно ',b.ElementsByRow.Average)
end.

Пример
Количество строк и столбцов в массиве: 3 4
1 2 3 4
2 3 4 5
3 4 5 6
   1   2   3   4
   2   3   4   5
   3   4   5   6

Ср.арифм. равно 3.5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?