В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
danilasavap0a3nj
danilasavap0a3nj
07.04.2020 15:38 •  Информатика

20 составить программу, которая вводит 3 числа и ставит их в порядке убывания

Ответ:
20kokosik26
20kokosik26
08.10.2020 09:01
var  
a, b, c: integer;  

begin  

Read(a, b, c);  
if ((a > b) and (a > c) and (b > c)) Then    
Write(a, ' ', b, ' ', c)  
else  
if ((b > a) and (b > c) and (a > c)) Then    
Write(b, ' ', a, ' ', c)  
else  
if ((c > a) and (c > b) and (a > b)) Then    
Write(c, ' ', a, ' ', b)  
else  
if ((b > a) and (b > c) and (c > a)) Then    
Write(b, ' ', c, ' ', a)  
else    
Write(a, ' ', c, ' ', b)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?