В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kukushka2281337
Kukushka2281337
01.01.2021 23:08 •  Информатика

Составьте программу , определяющую , является ли введенное слово числом. pascal.

Ответ:
RFTBOY
RFTBOY
08.10.2020 08:23
PascalABC.NET 3.3.5, сборка 1648 от 31.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var r:real;
  real.TryParse(ReadlnString,r).Println
end.

Примеры
-345.432
True

+253432
True

1.52e-14
True

15,3
False
0,0(0 оценок)
Ответ:
ankaschamina20
ankaschamina20
08.10.2020 08:23
Var s: string; I,n,k,L:longint; Begin Readln(s); L:=length(s); If s[1]<>'-' then begin For i:=1 to L do If s[i] in ['1'...'9'] or (s[i]='.' and s[i+1]<>'.') then inc(k); If k<>L then writeln('слово') else writeln('число'); End else begin For i:=2 to L do If (s[i] in ['1'...'9']) or (s[i]='.' and s[i+1]<>'.')then inc(k); If k<>(L-1) then writeln('слово') else writeln('число'); End; End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?