В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olaved1
olaved1
06.07.2021 23:07 •  Информатика

Написать программу, используя три вида циклов (цикл с параметром, цикл с предусловием и цикл с постусловием) исходная формула : z=tg (t-cost) значение аргумента : t=14; 15; 16; 17; 18; 19 заранее

Ответ:
Kolyan2003best
Kolyan2003best
08.10.2020 08:21
Program tg;
var z:real;
t:integer;
begin
t:=14;
for t:=14 to 19 do
begin
z:=sin(t-cos(t))/cos(t-cos(t));
writeln('z=', z);
end;
end.

Program tg;
var z:real;
t:integer;
begin
t:=14;
while t<=19 do
begin
z:=sin(t-cos(t))/cos(t-cos(t));
writeln('z=', z);
t:=t+1;
end;
end.

Program tg;
var z:real;
t:integer;
begin
t:=19;
repeat
z:=sin(t-cos(t))/cos(t-cos(t));
writeln('z=', z);
t:=t-1;
until t=13;
end.

Написать программу, используя три вида циклов (цикл с параметром, цикл с предусловием и цикл с посту
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?