В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

4. составить программу для решения следующей . (уровень а): даны катеты прямоугольного треугольника a и b. найти его площадь s=½*a*b. (уровень b): дано целое число. если оно кратно 3, то удвоить его. в противном случае уменьшить его на величину остатка отделения этого числа на 3. вывести полученное число. (уровень c): найти сумму положительных нечетных чисел, меньших 100.

Ответ:
ilia39loh
ilia39loh
08.10.2020 07:31
Реализация на с++

Уровень А
#include<iostream.h>

using namespace std;

int main(){
  int a,b;
  cin >>a >> b;
  double s = 0.5 * a * b;
  cout << s << endl;
  return 0;
}
Уровень B
#include<iostream.h>

using namespace std;

int main(){
  int n;
  cin >> n;
  (n%3==0) ? n*2 : n+n%3;
  cout << n << endl;
  return 0;
}
Уровень C
#include<iostream.h>

using namespace std;

int main(){
  int summa = 0;
  for(int i = 1; i < 100; i+=2){
     summa += i;
  }
  cout << summa << endl;
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?