В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kozhoeva2003
kozhoeva2003
30.03.2021 09:55 •  Информатика

Напишите программу для проверки таблицы умножения. перемножаются числа от 2 до 9 ( числа через датчик случайных чисел). количество вопросов не менее 10. можно предусмотреть подсчёта количества правильных и неправильных ответов. в паскаль!

Ответ:
Белыйснег35
Белыйснег35
08.10.2020 07:21
//PascalABC.NET

begin
  var a,b,c:integer;
  var k:=0;
  for var i:=1 to 10 do
   begin
   a:=random(2,9);
   b:=random(2,9);
   write(a,'*',b,' = ');
   readln(c);
   if a*b=c then k:=k+1;
   end;
  writeln('Правильных ответов: ',k,', неправильных: ',10-k);
end.

Пример:
8*4 = 32
7*5 = 40
3*6 = 18
2*8 = 16
3*9 = 27
6*5 = 20
6*7 = 42
6*9 = 54
7*8 = 56
2*4 = 8
Правильных ответов: 8, неправильных: 2
0,0(0 оценок)
Ответ:
zhenya4546
zhenya4546
08.10.2020 07:21

program HelloWorld;

var i,res,ok: integer;

var a,b: integer;

begin

    ok:=0;

    for i:=1 to 2 do

    begin

        a:=2+random(7);

        b:=2+random(7);

        write('Сколько будет ');write(a);write(' умножить на ');write(b);writeln(' ?');

        readln(res);

        if res = a*b then ok:=ok+1;

    end;

    write('Правильных ответов:  ');writeln(ok);

   

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?