Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
logan323
23.03.2023 17:43 •
Информатика
Написать программу вычисления а10, где а - данное число если получившаяся программа требует более четырех умножений (использование функции sqr тоже считается умножением), то дать более экономное решение.
Ответ:
zulfiya2006
08.10.2020 07:07
Var a,a2,a4,a8,a10:integer;
begin
readln(a);
a2:=a*a; // a^2
a4:=a2*a2; // a^4
a8:=a4*a4; // a^8
a10:=a8*a2; // a^10
writeln(a10);
end.
Пример:
2
1024
0,0
(0 оценок)
Популярные вопросы: Информатика
FaceSwapLive
12.05.2022 17:16
C++ от острова буяна до царства славного салтана месяц пути. капитан корабля записывает в вахтенный журнал количество миль, пройденных за день. определить, в какую десятидневку...
nugumanovsalavp092yo
01.11.2021 17:00
Числа Фибоначчи строятся следующим образом: первые два равны единице, а каждое следующее равно сумме двух предыдущих. Например, первые десять чисел Фибоначчи равны: 1, 1, 2, 3,...
BULATIKSPB
21.12.2021 01:48
Структура операторов Выберите один ответ: a. из выражений, символов и частей b. из символов, выражений и лексем c. только из лексем d. только из лексикона e. из лексем и символов...
vovaq6oziu5d
23.11.2022 04:31
Сколько it специалистов в китае, за 2018 год...
BlackSenpai
07.11.2021 10:12
Выведите на экран все слова сообщения, записанные с большой буквы.(regex javascript)...
fantomidri
18.01.2023 15:13
206^1 125^10 = a2= a6 10 110 111^2=a10 0,34^8 =a10...
borisovak468
25.09.2022 23:05
Народ, тут у меня на python 3.8.0 проблемы с кодировкой. русский читать не хочет. попробовал перевести в юникод и вставить в программу - не прокатило. что делать?...
Кошка200511
18.10.2022 15:53
Створіть список улюблених фруктів. Напишіть серію команд if, elif, else для перевірки присутності фруктів у списку. Якщо фрукт входить у ваш список, то вивести повідомлення, наприклад:...
dasha010598
30.07.2022 00:16
Написать программу для С#!Написать программу решения следующей задачи: Определить, является ли «счастливым» трамвайный билет с шестизначным номером («счастливым» считается билет,...
Marmar20052110
01.06.2023 09:09
Возьмите любую АИС доступную в сети Интернет и опишите для чего она предназначена...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln(a);
a2:=a*a; // a^2
a4:=a2*a2; // a^4
a8:=a4*a4; // a^8
a10:=a8*a2; // a^10
writeln(a10);
end.
Пример:
2
1024