В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Qwiq
Qwiq
20.07.2020 23:04 •  Информатика

Написать программу на с и на с++,вычислить расстояние между двумя точками с данными координатами (х1 у1)и (х2 у2) .я вот что-то сделала но неправильно #include
#includ
void main()
{float x1,y1,x2,y2;
cout("x1,y1,x2,y2");
cin (%f,%f,%f,%f,& x1,& y1,& x2,& y2);
d: sqrt((pow (x1-x2,2) *po(y-y2,2))
}

Ответ:
irinavlasova
irinavlasova
08.10.2020 06:57

#include <iostream>

#include <cmath>

int main()

{

 float x1, y1, x2, y2;

 std::cout << "x1 :" << std::endl;

 std::cin >> x1;

 std::cout << "y1 :" << std::endl;

 std::cin >> y1 ;  

 std::cout << "x2 :" << std::endl;

 std::cin >> x2;  

 std::cout << "y2 :" << std::endl;

 std::cin >> y2;  

 float result = std::sqrt((std::pow(std::abs(x1-x2), 2) + std::pow(std::abs(y1-y2), 2)));

 std::cout << result << std::endl;

 char * temp = new char[0]();  

 std::cin >> temp;

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?