Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
bon332
20.03.2022 05:29 •
Информатика
Написать программу, определяющую сумму/количество элементов массива, кратных 3, но не кратных 5. на языке с++
Ответ:
357853
08.10.2020 07:13
#include <iostream>
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 15 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if ( !(num % 3) && num % 5 ) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
samuray99
25.10.2021 08:06
Случай заражения пк вирусом 1)путь заражения 2)какие действия производил вирус 3)как справились с проблемой 4)вывод...
lolololololf
03.01.2023 03:04
Вычислитe сумму элементов одномерного массива а, состоящего из 10 элементов...
riborg250000000
09.08.2021 17:45
Указать правильную тройку из ряда: «объект-натурная модель-информационная модель» а) человек – анатомический скелет – медицинская карта б) здание – пенопластовый макет – проект в)...
golenkova240620
02.02.2023 10:06
УМОЛЯЮ ИНФОРМАТИКА Задание 3 , установитк соответствие....
charlie911
27.05.2020 03:35
Некоторое число в двоичной системе счисления записывается как 1000110. Определите число и запишите его в ответе в десятичной системе счисления...
grachev791
13.02.2021 00:17
Укажите жизненные ситуации, в которых осуществляется обработка информации. Укажите один или несколько правильный вариантов ответа Водитель останавливается на красный сигнал светофора...
autosteklo777
30.08.2020 00:23
Организм человека согревается в основном за счет: а) мышечной дрожи б) теплой одежды в) метаболизма г)потоотделения...
AlminaLaipanova
30.08.2020 00:23
(с )определите вес и силу тяжести действующую на вас...
Alexader2352
30.08.2020 00:23
Разобрать по составу слово : намерение....
Job121
30.08.2020 00:23
Решить , саша вышел в 8 утра, через 15 минут за ним выбежала собака.через сколько минут она его догонит, если бежит со скоростю 310 м\мин,а он идет 260 м\мин...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 15 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if ( !(num % 3) && num % 5 ) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}