Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
nikita228wwx
01.09.2022 05:50 •
Информатика
Нужно написать программу на с++ мы вводим массив из букв, а программа должна их отсортировать по алфавиту
Ответ:
Fdcsxdxdvrcfcr
08.10.2020 05:55
#include <iostream>
#include <string>
using namespace std;
int main()
{
string S;
cin >> S;
int Mass[52];
for (int i = 0; i < 52; i++)
{
Mass[i] = 0;
}
for (int i = 0; i < S.length(); i++)
{
char c = S[i];
if (c >= 'a'&&c <= 'z')
{
Mass[(int)(c-'a')*2]++;
} else if (c >= 'A'&&c <= 'Z'){
Mass[(int)(c-'A')*2+1]++;
}
}
for (int i = 0; i < 52; i++)
{
for (int j = 0; j < Mass[i]; j++)
{
cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));
}
}
return 0;
}
Пример работы программы:
0,0
(0 оценок)
Популярные вопросы: Информатика
dfhhu
06.11.2020 22:56
Дай характеристику дистанционнму виду управления роботом. нужно ...
xato2003
06.11.2022 10:58
(a1+)(a-2)(a-3) (3a-2)(a+3)(a-7)...
lnatahozqc8g
26.05.2020 18:24
Плотность газовой смеси, состоящей из СО и СО2, по воздуху составляет 1,214. Определить состав в мольных (объёмных) долях...
Влад1488228
26.05.2020 18:24
Дві точки поділяють коло на дві дуги у відношенні 5 : 7. Знайдіть градусну міру меншої дуги кола....
jessikafox
26.05.2020 18:24
К каким жизненным выводам пришли герои в конце романа преступление и наказание...
Ameya
26.09.2020 12:24
A) Работа земского собора 1549 года 1) Расширение состава Боярской думы Б) венчание Ивана Грозного на царство 2) Составление «Домостроя» Сильвестром В) создание избранной Рады...
умняшка220
26.09.2020 12:24
Выберите вещества, молярная масса которых равна молярной массе углекислого газа (СО2).. Укажите один или несколько правильных вариантов ответа: N2O P4 SiO2 C3H8 NH3...
Sofia8787
26.09.2020 12:24
Що зробив Прометей для людей?...
dikray1
27.02.2020 02:06
Sudent s book In 1976 Michael Morpurgo* and hiswife Clare started the programme Farmsfor City Children . They now have threeTarms: in Devon, Wales and Gloucestershire, where...
Ozerck2002
15.07.2020 01:01
Как вы понимаете слова, сказанные о Достоевском? В нем совесть сделалась пророком…...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <string>
using namespace std;
int main()
{
string S;
cin >> S;
int Mass[52];
for (int i = 0; i < 52; i++)
{
Mass[i] = 0;
}
for (int i = 0; i < S.length(); i++)
{
char c = S[i];
if (c >= 'a'&&c <= 'z')
{
Mass[(int)(c-'a')*2]++;
} else if (c >= 'A'&&c <= 'Z'){
Mass[(int)(c-'A')*2+1]++;
}
}
for (int i = 0; i < 52; i++)
{
for (int j = 0; j < Mass[i]; j++)
{
cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));
}
}
return 0;
}
Пример работы программы: