В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Андрей201711
Андрей201711
17.11.2022 00:03 •  Информатика

Написать программу, которая запрашивает массив из n элементов, а затем делит все элементы массива на минимальный элемент. протестировать программу на пассивах размерностью 5 и 10 элементов.

Ответ:
Vjjiychyuy
Vjjiychyuy
08.10.2020 05:33
Программа со статическим массивом:

Var
  M: array[1..32767] of real;
  Min: real;
  N, i: integer;
Begin
  Write('N = ');ReadLn(N);
  if (N <= 0) then
    WriteLn('Количество элементов должно быть положительно')
  else
  begin
    Write('Введите элементы массива в количестве ',N,' штук');
    For i:= 1 to N do
      Read(M[i]);
    Min := M[1];
    For i:= 2 to N do
      if (M[i] < Min) then
        Min := M[i];
    WriteLn;
    Write('Получившийся массив:');
    For i:= 1 to N do
    begin
      M[i] := M[i] / Min;
      Write(' ',M[i]);
    end;
  end
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?