В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sayanasssss
sayanasssss
22.08.2021 05:50 •  Информатика

Даны натуральное число n (< 50) и числовой массив а[1..n]. составить программу, которая определяет сумму минимального элемента множества {а1; а3; } и максимального элемента множества {а2; а4; }.

Ответ:
klimenkovlad598
klimenkovlad598
08.10.2020 05:19
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-99,99); a.Println;
  var minOdd:=Range(0,n-1,2).Select(i->a[i]).Min;
  var maxEven:=Range(1,n-1,2).Select(i->a[i]).Max;
  Writeln('Искомая сумма равна ',minOdd+maxEven)
end.

Пример
n= 15
-44 -48 -14 63 -34 27 -16 66 15 -17 -33 69 53 58 -31
Искомая сумма равна 25
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?