Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Евгеша200111
23.11.2020 07:49 •
Информатика
Найти сумму цифр в паскале (используя while или repeat) s=101+103+ +301 составить программу.
Ответ:
Polina011020040
08.10.2020 05:17
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!
1. Современное решение (приводится в качестве контрольного примера, дающего эталон суммы).
begin
Range(101,301,2).Sum.Println
end.
Результат
20301
2. Цикл while
begin
var (i,k,s):=(101,301,0);
while i<=k do begin s+=i; i+=2 end;
s.Println
end.
3. Цикл repeat
begin
var (i,k,s):=(101,301,0);
repeat
s+=i; i+=2
until i>k;
s.Println
end.
Результаты выполнения всех трех программ одинаковы.
0,0
(0 оценок)
Ответ:
YungTrappa1
08.10.2020 05:17
(использую repeat)
var i,S:integer;
begin
S:=0; i:=101;
repeat
S:=S+i; i:=i+2;
until i>301;
Writeln(S);
end.
(использую While)
var i,S:integer;
begin
S:=0; i:=101;
while i<=301
do begin
S:=S+i; i;=i+2;
end;
Writeln(S);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
korolovk
06.06.2023 17:43
100 мб + 260 гб – 120 кб + 8000 байт – одна треть тб + 3 бита ответ выразите в битах....
alena1706
14.02.2022 06:10
Сочинение на тему интернет - безопасен или нет? напишите ...
naklus
14.08.2022 16:30
Менеджер находится в командировке. ему необходимо важную для фирмы информацию.в его распоряжении находится только карта памяти, на которую можно поместить 64 гбайт.на...
naxim23432
25.05.2022 04:44
Запишите последовательность действий для работы при рисовании буквы Т. ...
заразарема
04.04.2023 18:16
Дан фрагмент текста до (слева) и после (справа) форматирования. В обоих вариантах используется шрифт одного семейства (гарнитуры) Times New Roman. Если присмотреться к...
катяkfrr
03.12.2021 14:01
Задана квадратная матрица, состоящая из целых чисел. Сформировать вектор из произведения элементов столбцов и найти их среднее арифметическое. Напишите алгоритм, как сформировать...
KINGMe
10.12.2020 10:06
Найти объем информации, содержащейся в тексте из 3000 символов, и написанном с использованием алфавита, содержащего 87 символа....
илья1948
04.06.2020 15:46
Выполните перевод 13810 в 2СС; 8СС; 16СС заранее...
mousi1999
13.06.2022 10:00
Два текста содержат одинаковое кол-во символов . первый текст составлен из символов алфавита мощностью 256 символов, второй - мощностью 32 символа . во сколько раз различаются...
4epHo3eM
13.06.2022 10:00
Напишите программу минимального элемента массива (в бейсике)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
1. Современное решение (приводится в качестве контрольного примера, дающего эталон суммы).
begin
Range(101,301,2).Sum.Println
end.
Результат
20301
2. Цикл while
begin
var (i,k,s):=(101,301,0);
while i<=k do begin s+=i; i+=2 end;
s.Println
end.
3. Цикл repeat
begin
var (i,k,s):=(101,301,0);
repeat
s+=i; i+=2
until i>k;
s.Println
end.
Результаты выполнения всех трех программ одинаковы.
var i,S:integer;
begin
S:=0; i:=101;
repeat
S:=S+i; i:=i+2;
until i>301;
Writeln(S);
end.
(использую While)
var i,S:integer;
begin
S:=0; i:=101;
while i<=301
do begin
S:=S+i; i;=i+2;
end;
Writeln(S);
end.