В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
juliajulia005
juliajulia005
10.10.2021 13:44 •  Информатика

Составить программу в с++ печатающую true, если указанное высказывание является истинным, и false - в противном случае: 1) цифры данного трехзначного числа являются членами арифметической прогрессии. 2) сумма каких-либо двух цифр заданного трехзначного числа равно третьей цифре.

Ответ:
bulyginanastya
bulyginanastya
04.08.2020 16:49
Int main(){
char input[4]; cin >> input;
// Задание 1 if ((int)input[0] - (int)input[1] == (int)input[1] - (int)input[2]) cout << "TRUE\n"; else cout << "FALSE\n";
// Задание 2
int a = (int)input[0] - 48; int b = (int)input[1] - 48; int c = (int)input[2] - 48;
if ( a + b == c || c + b == a || c + a == b) cout << "TRUE"; else cout << "FALSE";

system("pause"); return 0;}
Составить программу в с++ печатающую true, если указанное высказывание является истинным, и false -
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?