В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
afsanka98
afsanka98
09.05.2020 06:23 •  Информатика

Склавиатуры вводится 2 угла и 3 стороны треугольника,написать программу,которая определяет вид треугольника(прямоугольный,равнобедренный,равносторонний,тупо угольный, остроугольный)на c+

Ответ:
помогите5132
помогите5132
08.10.2020 04:19
#include "iostream"
using namespace std;
int main(){
int Angle1= 0, Angle2 = 0, Angle3;
cin >> Angle1;
cin >> Angle2;
Angle3 = 180 - (Angle1 + Angle2);
if ((Angle1 == 90) | (Angle2 == 90) | (Angle3 == 90))
{
 cout << "Pryamougolniy" << endl;
 }
if ((Angle1 > 90) | (Angle2 > 90) | (Angle3 > 90))
 {
 cout << "Tupougolniy" << endl;
}
if ((Angle1 == Angle2) && (Angle2 == Angle3))
{
 cout << "Ravnostoronniy" << endl;
 }
if (((Angle1 == Angle2) & (Angle2 != Angle3)) | ((Angle1 == Angle3) & (Angle1 != Angle2)) | ((Angle2 == Angle3) & (Angle2 != Angle1)))
{
  cout << "Ravnobedrenniy" << endl;
 }
system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?