В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Минут505
Минут505
05.05.2020 02:28 •  Информатика

Напишите программу на языке паскаль для решения дано четырёхзначное число х. найти: a. число десятков в нем; b. число единиц в нем; c. число сотен в нем; d. число тысяч в нем; e. сумму его цифр; f. произведение его цифр.

Ответ:
алёчек
алёчек
16.08.2020 19:20
Uses crt;
var input, betw:integer;
begin         
readln(input);                  
betw := input;          
betw := betw div 10;         
betw := betw div 10;         
betw := betw div 10;
      
writeln('Тысяч = ', betw); 
                
betw := input;         
betw := betw div 10;         
betw := betw div 10;         
betw := betw mod 10;                  
writeln('Сотен = ', betw);                 
betw := input;         
betw := betw div 10;         
betw := betw mod 10;                  
writeln('Десятков = ', betw);                           
betw := input;         
betw := betw mod 10;                  
writeln('Единиц = ', betw);        end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?