В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sulti1675gmailcom
sulti1675gmailcom
08.02.2023 06:54 •  Информатика

Составить блок-схему и написать программу в эвм вводятся по очереди координаты n точек. определить, сколько из них попадает в круг радиусом r с центром в точке (a,b).

Ответ:
lanchik03
lanchik03
08.10.2020 02:51
Блок-схема - в прилагаемом файле.
Программа:
var n,r,a,b,k,x,y,i:integer;
begin
readln(n,r,a,b);
k:=0;
for i:=1 to n do
 begin
 readln(x,y);
 if sqr(x-a)+sqr(y-b)<r*r then k:=k+1;
 end;
writeln('k = ',k);
end.

Пример:
3 4 1 1
2 2
-2 -3
0 0
k = 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?