В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gorodkatya
gorodkatya
26.03.2023 00:38 •  Информатика

Составить алгоритм и написать программу позволяющую найти сумму элементов массива с четными номерами содержащего n элементов заполнение массива организовать натуральными числами в порядке убывания надо

Ответ:
Данилкакрутой
Данилкакрутой
01.09.2020 18:52
Блок-схема - в прилагаемом файле.
Программа:
const n=10;
var a:array[1..n] of integer;
s,i:integer;
begin
for i:=1 to n do begin
 a[i]:=n-i+1;
 write(a[i],' ');
 end;
writeln;
s:=0;
for i:=1 to n div 2 do s:=s+a[2*i];
writeln('s = ',s);
end.

Результат:
10 9 8 7 6 5 4 3 2 1
s = 25
Составить алгоритм и написать программу позволяющую найти сумму элементов массива с четными номерами
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?