В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
jroslov
jroslov
30.04.2020 22:21 •  Информатика

По информатике составить программу в паскале.создать одномерный массив а из 10 целых чисел (с рандома в диапазоне (-50; 100). посчитать количество отрицательных и неотрицательных элементов массива.

Ответ:
helpme148
helpme148
08.10.2020 02:26
// PascalABC.NET 3.3
begin
  var a:=ArrRandom(10,-50,100); a.Println;
  var k:=a.Where(x->x<0).Count;
  writeln('Количество отрицательных = ',k,
          ', количество неотрицательных = ',10-k);
end.

Пример:
66 47 65 70 -3 81 45 70 -33 -31
Количество отрицательных = 3, количество неотрицательных = 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?