В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу: попугай рома вытягивает каждый из семи дней случайным образом число от 1 до 10. сколько чётных и сколько нечётных чисел он вытянул за неделю.

Ответ:
ron22218a
ron22218a
08.10.2020 02:07
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(7,1,10); a.Println;
  var kOdd:=a.Where(t->t.IsOdd).Count;
  Writeln(kOdd,' нечетных, ',7-kOdd,' четных')
end.

Пример
7 2 3 4 2 5 3
4 нечетных, 3 четных
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?